Excel-lence

Catégories
Excel VBA

La face cachée de la fonction SOMMEPROD de Excel

La fonction SOMMEPROD dans Excel cache quelques secrets. En effet, la version décrite et affichée par Excel n’est en fait qu’une seule de ses formes

  • La fonction SOMMEPROD telle qu’affichée par Excel

La fonction Sommeprod sous sa forme de base est peu utilisée, à moins d’être dans des domaines bien précis de sciences et de mathématiques, dû à ce qu’elle fait.

En effet, celle-ci permet de multiplier deux matrices, bien que ce type soit peu intéressant.

Sa structure est : =SOMMEPROD (Plage1 ; Plage2)

Exemple de calcul :

  =SOMMEPROD(A2:A3 B2:B3) à (A2 x B2) + (A3 x B3)
  • La face cachée de la fonction SOMMEPROD

Cette variante de la fonction SOMMEPROD est vraiment très utile pour les utilisateurs d’Excel VBA, bien qu’elle soit méconnue par la plupart des utilisateurs et presque jamais enseignée. Lorsque nous avons une base de données, qu’elle soit saisie ou bien importée sur Microsoft Excel à partir d’Access Fichier Txt ou de la plupart des entrepôts de données et de systèmes comptables, elle fait la somme d’une ou plusieurs colonnes lorsque les conditions sont vraies dans d’autres colonnes.

Sa structure est :

 = SOMMEPROD((Plage = Condition)*(plage à additionner))

Dans cette fonction, le signe * est un séparateur d’arguments et non un signe de multiplication.

Il n’y a pas de limite au nombre de conditions utilisées.

= SOMMEPROD((Plage = Condition)*(Plage2 = Condition2)*(Plage3 = Condition3)*(plage à additionner))

D’autres opérateurs mathématiques peuvent être utilisés dans les conditions telles que ( < > = ).

Laisser un commentaire

Votre adresse e-mail ne sera pas publiée.