Excel-lence

Catégories
Excel VBA

La face cachée de la fonction SOMMEPROD de Excel

La fonction SOMMEPROD dans Excel cache quelques secrets. En effet, la version décrite et affichée par Excel n’est en fait qu’une seule de ses formes

  • La fonction SOMMEPROD telle qu’affichée par Excel

La fonction Sommeprod sous sa forme de base est peu utilisée, à moins d’être dans des domaines bien précis de sciences et de mathématiques, dû à ce qu’elle fait.

En effet, celle-ci permet de multiplier deux matrices, bien que ce type soit peu intéressant.

Sa structure est : =SOMMEPROD (Plage1 ; Plage2)

Exemple de calcul :

  =SOMMEPROD(A2:A3 B2:B3) à (A2 x B2) + (A3 x B3)
  • La face cachée de la fonction SOMMEPROD

Cette variante de la fonction SOMMEPROD est vraiment très utile pour les utilisateurs d’Excel VBA, bien qu’elle soit méconnue par la plupart des utilisateurs et presque jamais enseignée. Lorsque nous avons une base de données, qu’elle soit saisie ou bien importée sur Microsoft Excel à partir d’Access Fichier Txt ou de la plupart des entrepôts de données et de systèmes comptables, elle fait la somme d’une ou plusieurs colonnes lorsque les conditions sont vraies dans d’autres colonnes.

Sa structure est :

 = SOMMEPROD((Plage = Condition)*(plage à additionner))

Dans cette fonction, le signe * est un séparateur d’arguments et non un signe de multiplication.

Il n’y a pas de limite au nombre de conditions utilisées.

= SOMMEPROD((Plage = Condition)*(Plage2 = Condition2)*(Plage3 = Condition3)*(plage à additionner))

D’autres opérateurs mathématiques peuvent être utilisés dans les conditions telles que ( < > = ).

Catégories
Excel VBA

Pourquoi en 2022 VBA Excel reste le numéro 1 des projets d’automatisation

VBA va disparaître, c’est la mort de VBA, Microsoft n’utilise plus VBA dans le pack office …Des informaticiens annonçaient depuis 2000 ! Mais jusqu’au 2020 ils sont entrain de répéter leurs prédictions alors que des millions des applications en VBA Excel sont en train de se réaliser 🙂
Pourquoi VBA n’est pas disparut et ne serait jamais !

Dans le monde de l’informatique , les nouveautés s’accélèrent , des nouvelles technologies prennent leurs places dans le marché au dépend des plus anciennes, et il parait impossible de pouvoir suivre le rythme de l’innovation technologique.

Pourtant , certains outils ont menti toutes les prédictions et ils ont résisté à ces tsunamis , année après année.

Sans doute, l’exemple le plus pertinent est le VBA Excel, qui continue à s’imposer dans les entreprises comme étant l’outil numéro 1 de l’automatisation.

Le VBA digne sa résistance à plusieurs raisons :

1- La puissance inégalée de logiciel Excel (Calcul , reporting , traitement des données,..)

2- Excel est utilisé par plus qu’un Milliard d’utilisateurs dans le monde entier

3- La documentation est disponible en ligne et vous y accédez depuis l’éditeur VBA.

4- Le support technique est omniprésent. Si un collègue ne connaît pas la réponse, vous pouvez facilement la trouver dans l’un des nombreux forums d’aide et sites Web gérés par des experts.

Catégories
Excel VBA

Langage M de Power Query

Power Query est un outil que dispose Excel, et qui permet de créer un classeur qui se connecte aux données externes, les transformer et de créer un modèle de données. Il utilise un langage spécifique qui s’appelle Langage M. En traitant un exemple on va explorer des notions de bases pour ce langage.

Pour construire notre modèle des données en Power Query , on commence par se connecter à la source des données, dans notre exemple c’est un fichier Excel qui s’appelle « État des articles » constitué des colonnes suivantes :

Code Article Ventes annuelles Stock Commande encours Prévisions Encours Production
Catégories
Excel VBA

EXCEL ET ART !

Tatsuo Horiuchi est un artiste japonais hors-du-commun. Ce peintre âgé de 73 ans réalise ses peintures grâce au logiciel Excel, habituellement réservé aux calculs numériques et au traitement de données.

Pourquoi ? « Après mon départ en retraite, je recherchais un nouveau défi, et vu le prix élevé des logiciels spécialisés, j’ai décidé d’utiliser Excel, déjà pré-installé sur mon ordinateur » explique l’artiste.

Il est possible de télécharger les fichiers de ses tableaux sur son site web.